21/09/15

Cara Setting Load Balancing Speedy dan Selullar

Kali ini saya akan membagikan tutorial penggunaan dan penerapan load balancing dan failover pada router mikrotik. Load balancing pada mikrotik memiliki lebih dari satu metode. Akan tetapi penggunaan metode yang sering dipakai yaitu menggunakan metode Nth dan PCC. Pada kesempatan kali ini, saya akan membagikan cara setting load balancing dengan metode Nth. Motode LB ini sangat cocok bagi ana yang ingin memiliki bandwith yang lebih. Akan tetapi perlu diingat, setiap metode memiliki segi kelebihan dan kekurangan. Metode Nth sendiri memiliki karakteristik meng-acak (random) gateway pada saat mengakses sebuah alamat. Jadi sangat tidak cocok untuk penggunaan yang menerapkan lock ip seperti halnya game online, internet banking dan lain sebagainya. Karena akan selalu logout dengan sendirinya.

Untuk topologinya disini saya akan menggabungan menggunakan RB751G-2HnD antara 1 ISP Speddy dan 2 Provider selullar .

Dengan Topologi sebagai berikut :


Asumsi tahap setting :
Modem ADSL Telkom Speedy adalah : 192.168.1.1
MikroTik interface 1 (Public) adalah : 192.168.1.2
MikroTik interface (Lokal) adalah : 192.168.0.1
Port USB 1 : Provider 3 three : IP address (Dynamic)
Port USB 2 : Provider M3 (Indosar) : IP address (Dynamic)
Primary DNS : 8.8.8.8 (sesuaikan dengan keinginan anda)
Secondart DNS : 8.8.4.4 (sesuaikan dengan keinginan anda)

Untuk tahap Settingannya adalah sebagai berikut:

1. Konfigurasi Interface :
Rubah Nama interface sebagai berikut:
- interface 1 : Public
- interface 2 : Lokal
- Port USB 1 : USB1
- Port USB 2 : USB2
untuk tahap pengaturan interface USB nya yaitu hanya pengubahan nama dan uncheck list (Dial on Demand, Use peer DNS dan Add Default Route)
Perlu diingat. penamaan interface jangan sampai salah, agar tahap settingan selanjutnya juga tidak salah, karena menggunakan terminal.


2. Penambahan Ip address :
Cukup menambahkan Ip address pada interface Public dan Lokal, karena ip yang didapat pada provider selular (interface USB) sudah otomatis (DHCP) saat melakukan panggilan koneksi.

/ip address
add address=192.168.1.2/24 broadcast=192.168.1.255 \
comment="" disabled=no interface=Public network=192.168.1.0
add address=192.168.0.1/24 broadcast=192.168.0.255 \
comment="" disabled=no interface=Lokal network=192.168.0.0


3. Penambahan DNS
/ip dns
set allow-remote-requests=yes cache-size=3072KiB \
max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4


4. Setting NAT

/ip firewall nat
add chain=srcnat action=masquerade out-interface=Public \
comment="" disabled=no
add chain=srcnat action=masquerade out-interface=USB1 \
comment="" disabled=no
add chain=srcnat action=masquerade out-interface=USB2 \
comment="" disabled=no


5. Yang paling penting adalah tahapan pengaturan pada Mangle.
untuk setting mangle bisa melalui terminal pada winbox

/ip firewall mangle
add chain=prerouting in-interface=Lokal connection-state=new nth=3,1 \
action=mark-connection new-connection-mark=to_jalur-1 \
passthrough=yes comment="LB Nth Rule 1" disable=no
add chain=prerouting in-interface=Lokal connection-state=new nth=3,2 \
action=mark-connection new-connection-mark=to_jalur-2 \
passthrough=yes comment="" disable=no
add chain=prerouting in-interface=Lokal connection-state=new nth=3,3 \
action=mark-connection new-connection-mark=to_jalur-3 \
passthrough=yes comment="" disable=no
add chain=prerouting in-interface=Lokal connection-mark=to_jalur-1 \
action=mark-routing new-routing-mark=to_jalur-1 \
passthrough=no comment="" disable=no
add chain=prerouting in-interface=Lokal connection-mark=to_jalur-2 \
action=mark-routing new-routing-mark=to_jalur-2 \
passthrough=no comment="" disable=no
add chain=prerouting in-interface=Lokal connection-mark=to_jalur-3 \
action=mark-routing new-routing-mark=to_jalur-3 \
passthrough=no comment="" disable=no


6. Tahap terakhir yaitu dengan penambahan IP Route, yang sebelumnya sudah dibuat sebuah proses kebijakan routing-mark pada setiap Provider.

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
192.168.1.1 comment="ROUTE LB" routing-mark=jalur-1 \
scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
USB1 routing-mark=jalur-2 scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
USB2 routing-mark=jalur-3 scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
192.168.1.1 comment="Default"

Dan inilah hasilnya. Load balancing dan failover dengan ISP line 1 Speedy dan 2 Provider Selular.
#Speedy Hanya menggunakan Paket 1Mbps.
Demikian tutorial yang saya berikan, semoga bermanfaat.

Share on Facebook
Share on Twitter
Share on Google+
Tags :

Related : Cara Setting Load Balancing Speedy dan Selullar

1 comments:

  1. kalau dibuat mode pcc bagaimana caranya pak?
    langka 1 - 4 sama kan caranya pak bila jadikan metode pcc?
    langka 5 sampai akhir bagaimana pak?
    terimakasih pak sebelumnya pak.

    BalasHapus